Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: The dreaded MUDMAN G9300 reset problem...

  1. #11
    Member nelamvr6's Avatar
    Join Date
    Dec 2014
    Location
    New London, CT. USA
    Posts
    60
    I'm just wondering if there is ANY common thread at all with the watches exhibiting this problem.

    Those who have had this problem, was you watch the JDM model, or the ER release?

  2. #12
    Member Rocat's Avatar
    Join Date
    Nov 2014
    Location
    South Carlina
    Posts
    212
    I hate that it happened to you Iyonk.

  3. Likes iyonk liked this post
  4. #13
    This is very sad to here as I really like the 9300 Mudman a lot and was planning on picking one up. It's a nice looking watch. Wanted to get the Japan model with Atomic. I don't think I'm going to buy one now as the Japan version is quite expensive.

    Yes it does seem that the more complex things get with features the more ways they can go wrong. You are right a standard 5600 or 6900 is probably the most reliable out of all the G-Shocks since they are so basic.

    I'm think I will buy a new standard 6900 for ultimate reliability and add a Suunto compass to the band. Then I'll have the toughest and most reliable compass watch available. Unfortunately this combo will be close to the price of the 9300 Mudman.

  5. Likes iyonk liked this post
  6. #14
    Happened once on my 9330 as well

  7. #15
    Member Rocat's Avatar
    Join Date
    Nov 2014
    Location
    South Carlina
    Posts
    212
    Between this model resetting and the Rangeman experiencing some broken/snapped lugs, it may be best to stick with the good old reliable models.

  8. Likes iyonk liked this post
  9. #16
    Member nelamvr6's Avatar
    Join Date
    Dec 2014
    Location
    New London, CT. USA
    Posts
    60
    Quote Originally Posted by Rocat View Post
    Between this model resetting and the Rangeman experiencing some broken/snapped lugs, it may be best to stick with the good old reliable models.
    I hadn't heard abot problems with Rangeman lugs either. Is this a thing now?

  10. #17
    it doesnt reset this morning... so i dont know the element that make it reset it self... i'm thinking of doing AC reset or swap the battery with my ws220..

    well, i'll do the AC reset today to eliminate this one as the issue... if the problem come back latter... i'll update this post...

    I'm with rocat... i'll stick to my humble DW5600 or screwback 5030c... it is the most basic features g-shock that i never encounter any glitch and definately reliable... the steelcase of the screwback also eliminates lug fail problem...



    i search about the problem last night and it is pretty common and randomly happened to G/GW9300... seem that it is sensitive to radio or even cellphone radiation ...
    to bad it happened to this one... it was one of my fav G that i used to recommend very often... what a let down issue..

  11. #18
    Just did the AC reset... the reason i did it so if the reset problem still exist-- you dont have to go thru the same route...

    I'm not comfortable to open a G, but since this one need trouble shooting, so i take some pics thru the process..
    DSCN8449.jpg

    DSCN8448.jpg

    its a very nicely build G with solid construction...

    and the AC is done... the display show that the caseback is still open
    DSCN8454.jpg


    the bonus pics are to show that the screw caseback holes ARE metal reinforced... dont know if the pics could show it but it definately clear when yo see them in person..
    DSCN8458.jpg

    and even the lug screw holes got metal insert... nice..

    DSCN8460.jpg



    lets see how it goes... i might experiment with putting it near my phones or even wifi router... yeah sounds silly but my theory is the big cooper wire inside the module might be sensitive with some interference...

    have a great day everybody..

  12. Likes Phantasm, Greg, Rocat liked this post
  13. #19
    G-Shock & Digital Moderator Kronos's Avatar
    Join Date
    Oct 2014
    Posts
    1,034
    Keep us posted!


    Sent from my iPhone using Tapatalk

  14. #20
    Member nelamvr6's Avatar
    Join Date
    Dec 2014
    Location
    New London, CT. USA
    Posts
    60
    Great pics, thanks! Good luck, I hope you don't have any more problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About Us
We are an independent and wide-ranging forum for watch enthusiasts. From mainspring to microchip, from Europe to Asia, from micro-brand to boutique - we cover it all. Novice or expert, we want you to feel at home. Whether it's asking a simple question or contributing to the fund of horological knowledge, it's all the same hobby. Or, if you like, you can just show us a picture of your new watch. We'll provide the welcoming and courteous environment, the rest is up to you!
Join us